Memperbaiki Error appcompat v7 pada Eclipse IDE (ADT)

Setiap membuat project baru menggunakan Eclipse IDE update terbaru, secara otomatis akan muncul folder project appcompat_v7. Tujuannya untuk memberikan compatibility terhadap versi Android sebelumnya, mulai dari API Level 8 (Android 2.2 Froyo). Namun, akan ditemui error pada folder project.

Lalu diikuti dengan error report yang tampil berturut-turut, kurang lebih seperti dibawah ini:

Continue reading Memperbaiki Error appcompat v7 pada Eclipse IDE (ADT)

Menggunakan ListView Android dengan ArrayAdapter

Penggunaan List View sangat direkomendasikan daripada menggunakan extends ListActivity, karena pada Android API terbaru saat ini diharuskan include Android Support Library (jika menggunakan Eclipse IDE, setiap membuat project baru akan muncul folder appcompat_v7) sehingga class melakukan extends terhadap ActionBarActivity.

Tujuan disediakannya Android Support Library untuk memberikan dukungan terhadap versi Android terdahulu, dimulai dari API Level 8 (Android 2.2 Froyo).

Berikut ini merupakan contoh sederhana penggunaan ListView dengan menggunakan ArrayAdapter:

Continue reading Menggunakan ListView Android dengan ArrayAdapter